SSL Heartbleed

An internet-wide security vulnerability called ‘Heartbleed’ affecting the OpenSSL framework was discovered on April 7th. In response, we conducted a thorough security review of our I.T. systems which concluded that our core systems, applications,  APIs, e-commerce platform, and customer data were not at risk. We did identify two peripheral servers which were susceptible to the vulnerability and these were patched immediately.
We are closely monitoring the situation and will provide an update should there be any further developments. If you have any questions or concerns please contact us on